1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Help with Canon EOS 70D

Discussion in 'ATG Cafe' started by Nishy, Dec 23, 2016.

  1. Nishy

    Nishy Guru Staff Member

    Hoping someone more knowledgeable may help me here. I was half way through shooting a shave video and the LCD screen started breaking up, then read error. Now cannot take a picture and the LCD screen remains blank/black. Video is not working either. I do get a focus verification through the manual view finder but nothing more.

    I did a little bit of research and perhaps the shutter is stuck? But cannot find any info on the blank screen situation.
     
  2. N_Architect

    N_Architect Veteran

    Location:
    ATH
    I think you may have to start eliminating possible reasons, in order to approach the true problem

    Did you get out of LV mode and try to shoot a simple shot? (simple photo, forget abt the video)
    LCD screen may still remain black, but we're doing this in order to first ascertain that the shutter works (and sounds) as should.
     
    Nishy likes this.
  3. jb7

    jb7 Bloke

    First thing to do is remove the battery for a few minutes, then re-insert and re-try to determine if the issue persists.
     
    Nishy likes this.
  4. JamieM

    JamieM Merthyr Tydfil, South Wales

    Could be the memory card?
     
    Nishy likes this.
  5. Nishy

    Nishy Guru Staff Member

    Thanks for the reply Gents, I removed the battery and tried a brand new memory card to no avail. Regarding shooting a simple shot, it won't take a picture at all. The AF points light up and the lens provides focus but when going to shoot the camera fails.

    Just tried it again and now the camera is not responding at all, it is completely dead, doesn't turn on, no focus no back light no options on the main body. Think I may have to return it.
     
  6. Andrimus

    Andrimus Regular Member

    Take the lens of and look is the shutter open or closed?
    Did you get any error locks before the blackout?
    How many hours have recorded videos in all?
    Just blowout my shutter in my 5d 4 at 950000 pictures
     
    Nishy likes this.
  7. Nishy

    Nishy Guru Staff Member

    Hiya, thank you for the advice. I did check the shutter and it is open. The camera has had very light use, I have had it for about a year max and the total hours of video would not even exceed 10 hours. Number of pictures is probably around the 10,000 mark. It's a baby.

    The LCD screen went 'fuzzy' and the main body's LCD display on the top of the camera read Error but without any code. The LCD screen then turned black and could not be used. The camera still focused and worked but without being able to take a picture (so just focus). However now the entire unit is dead and does not function.

    Did a little research and gut feeling is moisture damage I was shooting at -3 Celsius the night before, then left the camera in the room (at around 25 Celsius), it stopped working when in the bathroom (shooting a shaving video) and the temperature was around 27 Celsius. Nothing too extreme and no external water, but others have expressed similar issues with a small temperature range.
     
  8. Andrimus

    Andrimus Regular Member

    It sounds like the shutter is shot. It can happen even for new ones.
    You still have warranty ,because it's under two years old. Take it back to dealer.
    My old Nikon did the same in two months use.
     
    Nishy likes this.
  9. Nishy

    Nishy Guru Staff Member

    Thank you, I have been told off by the wife as I may have thrown the receipt away when cleaning (my own fault) and paid cash. Hopefully I can sort it out, it was bought from John Lewis and they are usually good with returns. May I ask if the shutter is shot, wouldn't the main body of the camera still function? Also over the course of the evening it has gone from working (just focusing no pictures) to being totally dead, to me this suggests moisture damage over mechanical failure, does this sound correct? Perhaps the moisture is damaging the electronics. In the morning the battery still registered as fully charged.
     
  10. Andrimus

    Andrimus Regular Member

    Working focusing and error at picture seems like shutter. I don't think that's from moisture .
    The shutter in this is the main thing in this body . It can be that or the chip that makes it work.
    The receipt should not be problem ,good firm have to keep the sales for two years.
    Next time you have new camera, register that with makers webpage . Then your camera history is easy to find.
     
    Nishy likes this.
  11. Nishy

    Nishy Guru Staff Member

    Thank you for the advice.
     
  12. N_Architect

    N_Architect Veteran

    Location:
    ATH
    All the best, Avnish - may be we see you with a new Canon from next week!
     
    Nishy likes this.
  13. Nishy

    Nishy Guru Staff Member

    Thank you my friend, I hope this is the case.
     
    N_Architect likes this.